Why worker version shown by fly is different from concourse version?


#1

When I tested upgrading from 4.2.2 to 5.0.0, I found that both 4.2.2 and 5.0.0 workers can mix together connecting to 5.0.0 ATC. But fly shows both workers as version 2.1.

name              containers  platform  tags  team  state    version
worker-PxVUvVtow  5           linux     none  none  running  2.1
worker-wyaIogcem  13          linux     none  none  running  2.1

Does worker has a separate versions than concourse?


#2

Yes they do.