Unable to connect with Vault

Hi,

I’ve deployed a concourse web node and worker node. The web node also has a hashicorp vault accessible on https://myvault.example. I’ve followed the instructions on https://concourse-ci.org/vault-credential-manager.html in setting up an approle. On the web node I have added the following env variables to /etc/envronment:

CONCOURSE_VAULT_URL=https://myvault.example
CONCOURSE_VAULT_AUTH_BACKEND=“approle”
CONCOURSE_VAULT_AUTH_PARAM=“role_id:1231231,secret_id:12312321”

I have the following pipeline:

 - name: hello-world
  plan:
  - task: say-hello
    config:
      platform: linux
      image_resource:
        type: docker-image
        source: {repository: alpine}
      run:
        path: echo
        args: [((test))]

If I run vault read concourse/main/test I get HLHLHLHLHLHLHLL (don’t ask) however when I run the pipeline I get:

failed to interpolate task config: Expected to find variables: test

Where do I begin to debug this? The web and worker nodes are not running in docker.

Any help would be greatly appreciated.

Start by checking your web / worker logs (probably web), and increase verbosity as needed.

I’ve checked through syslog on both the web and worker machines and nothing helpful there. Is there anyway of increasing the debug level or adding more debug into the pipeline to figure this out?

Finally figured it out.

I provisioned both the worker and web node using andrewrothstein.vault ansible role. This provides a wrapper script for both parts. When running the service it doesn’t read the environment variables set in /etc/environment so I’ve manually changed the run script to include them.