System requirements

Hi, im going to install Concourse ci on CentOS 5.8 or 7.6 x86_64,
however, Im not sure that it is correct kernel , arch or os ver.

im looking for the System Requirements of Concourse.
please tell me documentation url or knowledge.

The answer depends on how you’re deploying Concourse. In essence it is just a go binary. If you go to the latest release you can download the compiled binaries for 64bit linux. I would have thought this would work on CentOS since the compilation is handled by golang not Concourse.

That said, if this is more than a PoC you should consider deploying with something like BOSH, K8S, or docker which shouldn’t care what the base OS is. You can read more about these in this thread.

Dear, crsimmons.

Thank you for your reply.

handled by golang not Concourse.
docker which shouldn’t care what the base OS is.

I understand very well :smile:

Puppy