Running concourse web --help returns not found


#1

Hello Colleagues,

When I run concourse web --help on the worker node it returns me that “command not found”. From which path I need to run this or do i need to enable some flag ?

BRs, Gowrisankar


#2

You’re probably running docker run concourse/concourse concourse web --help?

That should be docker run concourse/concourse web --help if so - concourse is already the entrypoint, so all args are passed to it.


#3

@vito Actually We running a concourse bosh release, not docker. I logged in to the web node. From webnode no clue how to run this command …


#4

Look at the BOSH configuration file, see in which path it puts the concourse executable, invoke it with the full path ? Or equivalent, look in the systemd unit file for concourse and gather the path ? Or issue a find / -name concourse ?


#5

@marco-m
When I run the find command it gives me only the source files. there is no concourse executable.
I have checked in the all the folders no concourse executable found.
web/223c9600-efcb-4ea5-9057-f7078f0838f5:~# find / -name concourse
/var/vcap/data/packages/tsa/091b501ffaca66bb876b244db2ab54aad9682326/src/github.com/concourse
/var/vcap/data/packages/atc/96fb4054dda3d93fd51e4db6e481e286561bcf68/src/github.com/concourse
/var/vcap/data/packages/atc/96fb4054dda3d93fd51e4db6e481e286561bcf68/src/github.com/concourse/skymarshal/web/themes/concourse


#6

doesn’t the BOSH release use separate, specific binaries? e.g. “web” “worker” “tsa” “atc” etc? at least I think it did at one point (I never used BOSH myself)


#7

Yes, the BOSH release runs atc, worker, tsa, baggageclaim etc as independent binaries.