Not able to login to concourse UI


#1

Hi Team,

I have deployed concourse latest version with “add-local-user” parameter changes on kubernetes environment

env:
- name: CONCOURSE_ADD_LOCAL_USER
value: test:$2y$12$mLCjC0r4AIoJxuvRHlxgs.D4iCawcKcOmdRFZpx./JU0iWx3Td7kW

When I try to login to the concourse Ui, its redirecting to the below url:

sky/callback?code=sv5r7cw6fw3atl7s7xfwkrzny&state=eyJyZWRpcmVjdF91cmkiOiIvIiwiZW50cm9weSI6ImZkNWExMjBjZjU5NjE2N2FkOTc5ZWQyZjNlMmVkMmE3YTcwZjZhOGNlODUzZmY3NWJmMmE4ZGFjNTU3ZjEwNmUifQ%3D%3D

Thanks,
Sanjay


Login issue in 4.1.0
#3

We had this same issue. Tracked it down to a “Server Misbehaving” error in the ATC logs. Our server hostname was not resolving correctly. Fixed the DNS and we were able to login.


#4

Thanks for the info. We happen to be running it exclusively in our local network on a local IP 192.168.111.111 - with this setting: CONCOURSE_EXTERNAL_URL=http://192.168.111.111:8080

Are there any additional (new?) DNS settings for this setup to work?


#5

We are facing the same issue running the “add-local-user” setup on BOSH as cluster using concourse-bosh-deployment.

The landing page of Concourse displays but when i attempt to login, i receive a timeout.

Checked the atc logs and couldnt find anything special.

The tsa logs show the following error message:

{"timestamp":"1534151749.651492119","source":"tsa","message":"tsa.connection.channel.register-worker.register.failed-to-register","log_level":2,"data":{"error":"Post http://172.27.1.33:8080/api/v1/workers?ttl=1m0s: dial tcp 172.27.1.33:8080: connect: connection refused","remote":"172.27.1.32:54128","session":"1.1.1.777"}}

This is how our Concourse cluster looks like:

Deployment 'concourse'

Instance                                     Process State  AZ  IPs          VM CID                                   VM Type
db/e71d2095-b0ba-45fa-bc3b-738362e2c73f      running        z1  172.27.1.31  vm-83e705cd-3e5b-436f-a97d-67a892e94649  small
web/0577db48-bd59-4230-b963-8ef7e78e53df     running        z1  172.27.1.33  vm-c8ce4647-2bc4-433a-9933-3e8d65821938  medium
worker/1c13a2c1-4bc4-4d4e-81ec-e7fa7cb8ccb6  running        z1  172.27.1.32  vm-e4ebca76-bf33-43dd-a381-2db54c36cec6  large
worker/f0caf503-ff3c-4bc1-b06e-35d4b29b145a  running        z1  172.27.1.34  vm-c3de76b9-9aa3-4867-ac47-3f0c4ed86633  large

We are running the cluster on vSphere so there are no sec groups that could cause the conn refused from the IaaS side.


#6

@gdenn, did you make any progress ?


#7

@marco-m we could solve the problem, it was related tot he problem with he external-url which we configured wrong.

After setting the external url to our domain and performing ssl termination by our ha-proxy (concourse was complaining about the self signed cert) everything worked as expected.

best,
D