Ldap configuration with concourse bosh deployment


#1

Hi All,

While configuring concourse with bosh deployment, getting below error logs.

{“timestamp”:“1536965369.704052687”,“source”:“atc”,“message”:“atc.syncer.test-sleep:scheduler.start”,“log_level”:1,“data”:{“interval”:“10s”,“session”:“18.6”}}
{“timestamp”:“1536965382.261902094”,“source”:“atc”,“message”:“atc.sky.userinfo.failed-to-parse-authorization-header”,“log_level”:1,“data”:{“session”:“4.1”}}
{“timestamp”:“1536965382.292485237”,“source”:“atc”,“message”:“atc.sky.userinfo.failed-to-parse-authorization-header”,“log_level”:1,“data”:{“session”:“4.2”}}
{“timestamp”:“1536965390.260061979”,“source”:“atc”,“message”:“atc.dex.event”,“log_level”:2,“data”:{“fields”:{},“message”:“Failed to login user: failed to connect: LDAP Result Code 200 “Network Error”: tls: first record does not look like a TLS handshake”,“session”:“5”}}
{“timestamp”:“1536965466.442419052”,“source”:“atc”,“message”:“atc.sky.userinfo.failed-to-parse-authorization-header”,“log_level”:1,“data”:{“session”:“4.4”}}
{“timestamp”:“1536965466.473153114”,“source”:“atc”,“message”:“atc.sky.userinfo.failed-to-parse-authorization-header”,“log_level”:1,“data”:{“session”:“4.5”}}
{“timestamp”:“1536965473.534443378”,“source”:“atc”,“message”:“atc.dex.event”,“log_level”:2,“data”:{“fields”:{},“message”:“Failed to login user: failed to connect: LDAP Result Code 200 “Network Error”: tls: first record does not look like a TLS handshake”,“session”:“5”}}

Tried many combinations of ldap config parameters, but always getting above error.
Please suggest.

Thanks,
Umesh


#3

Version 4.2.0 installation resolved this issue.
The problem was in version 4.1.0. with LDAP configuration.

Thanks,
Umesh