Docker image resource: build args not always applying


#1

Hi!

We’re using concourse with the docker image resource. When using the build_args support, it seems like sometimes (but, confusingly, not always) the build args specified in the pipeline would be ignored, and the defaults from the Dockerfile are used instead. Sometimes it would only be part of the things (FROM ${arg} would apply successfully, but RUN … ${arg} would not, causing build failures). I’ve tried random things like moving lines up and down in the Dockerfile; however, the intermittent nature of the issue makes it hard to figure out if anything is fixed. My last attempt got things to build… for a few builds, before it stopped working again.

Has anybody seen similar issues with that resource / build_args support?

Just in case it’s an issue with changing images (since we’re using a docker image from Docker Hub rather than a resource shipped with concourse, after all), we’ve tried pinning it to an image. That didn’t seem to change anything.