Concourse with angular cli

I’m using concourse to test, compile and deploye to Pivotal Web Services an Angular 6.x front-end service using angular cli. If I deploy the service locally using: cf push -f manifest-cloud.yml everithing is Ok. But using the same manifest in a concourse pipeline don’t upload the dist compiled folder. These are my yalm scripts:

pipeline.yml:


jobs:

  • name: ci-training-cf-ui
    public: true
    serial: true
    plan:
    • get: training-cf-ui
      trigger: true
    • task: build-training-cf-ui
      file: training-cf-ui/ci/tasks/build-artifact.yml
    • put: deploy-training-cf-ui
      params:
      manifest: training-cf-ui/manifest-cloud.yml
      path: training-cf-ui/

resources:

build-artifact.yml:


platform: linux

image_resource:
type: docker-image
source:
repository: node

inputs:

  • name: training-cf-ui

run:
path: training-cf-ui/ci/tasks/build-artifact.sh

build-artifact.sh:

#!/bin/sh

set into source foulder

cd training-cf-ui

install dependencies

npm install

check angular cli version

npm install -g @angular/cli

compile in production mode (AOT mode)

ng build --prod

watching concourse task I observed that the angular compilation folder is /tmp/build/cb765ab6/training-cf-ui but when deploy the folder deployed is: /tmp/build/put/training-cf-ui is different, it provoques that the dist folder is not uploaded

What is the problem?

I resolve the problem adding a output atribute to the task in the build-artifact.yml file like this:

outputs:
– name: training-cf-ui-dist

and preparing a build folder in the build-articfact.sh file with the compiled and deployment artifacts like this:

cp package.json …/training-cf-ui-dist
cp server.js …/training-cf-ui-dist
cp -R ./dist …/training-cf-ui-dist
cp manifest-cloud.yml …/training-cf-ui-dist

Then use this folder in the pipeline.yalm in the PWS resource like this:

– put: deploy-training-cf-ui
params:
manifest: training-cf-ui-dist/manifest-cloud.yml
path: training-cf-ui-dist/

I’m following the same process that you have mentioned. But, I’m not able to skip the google analytics acceptance. Below is what I’m getting:

? Would you like to share anonymous usage data with the Angular Team at Google under
Google’s Privacy Policy at https://policies.google.com/privacy? For more details and
how to change this setting, see http://angular.io/analytics. (y/N)

I’m stuck here. How to skip this duration installation process?