Concourse 4.0.0 fails to start with message "server: no connectors specified"


#1

Hello,

I am trying to configure Concourse 4.0.0 with Google OAuth 2.0.

I have set the following environment variables:

CONCOURSE_BIND_IP=0.0.0.0
CONCOURSE_SESSION_SIGNING_KEY=/opt/concourse/keys/session_signing_key
CONCOURSE_TSA_HOST_KEY=/opt/concourse/keys/tsa_host_key
CONCOURSE_TSA_AUTHORIZED_KEYS=/opt/concourse/keys/tsa-authorized-keys
CONCOURSE_EXTERNAL_URL=XXXXX
CONCOURSE_POSTGRES_HOST=127.0.0.1
CONCOURSE_POSTGRES_USER=XXXXX
CONCOURSE_POSTGRES_PASSWORD=XXXXX
CONCOURSE_POSTGRES_DATABASE=concourse
CONCOURSE_MAIN_TEAM_ALLOW_ALL_USERS=1
CONCOURSE_GENERIC_OAUTH_DISPLAY_NAME=Google
CONCOURSE_GENERIC_OAUTH_CLIENT_ID=XXXXX
CONCOURSE_GENERIC_OAUTH_CLIENT_SECRET=XXXXX
CONCOURSE_GENERIC_OAUTH_AUTH_URL=https://accounts.google.com/o/oauth2/auth
CONCOURSE_GENERIC_OAUTH_TOKEN_URL=https://accounts.google.com/o/oauth2/token
CONCOURSE_GENERIC_OAUTH_AUTH_URL_PARAM=scope:profile,hd:example.com

However, concourse web fails to start with error message “server: no connectors specified”.

Does that error message mean that there is no authentication connector specified? How to configure Concourse to use the OAuth 2.0 authentication provider?

Best regards,
Jukka


#2

Hi, I’m also seeing a “server: no connectors specified” error message.
(At the moment I’m trying to follow the instructions at https://www.digitalocean.com/community/tutorials/how-to-install-concourse-ci-on-ubuntu-16-04)

I’m only dipping my toes in the concourse water, so am prepared to wait for a week or two while the documentation catches up with the 4.0.0 release.


#3

Keep in mind that the DigitalOcean tutorial you are referencing is out-of-sync and probably won’t work with the latest (4.0.0) concourse release. It’s best to follow the internal documentation: https://concourse-ci.org/setup-and-operations.html

Having said that - have you guys tested the GitHub authentication: https://concourse-ci.org/install.html#github-auth-config

I’m just asking, because it was very easy to configure and worked for me. The latest concourse release did forced me to change my deployment config a bit to get it all working again, though.


#4

Thanks for the reply - I was keen to try the LDAP authentication, which hasn’t made the internal documentation (yet) that I can see. I’ll keep an eye out for changes, though!


#5

You are probably right - there is some minimalistic amount of documentation in the cli help about LDAP (you could for example run docker run concourse/concourse web --help to view that)


#6

@r-chris thans for the hint. I ran into the same question and created a full working ldap example in my concourse boilerplate

https://github.com/EugenMayer/concourseci-server-boilerplate or more deep https://github.com/EugenMayer/concourseci-server-boilerplate/blob/master/docker-compose-ldap-auth.yml

it includes a concourse test setup with ldap (and vault and such) and also includes a test ldap server to test against - i guess thats the best way to understand the ldap settings / values. See the ldap test server docs github com/EugenMayer/docker-image-ldapexample to understand the server counterpart.

I included the user filter setup and the group setup, but actually it seems like either group assignements are not working, or assining main-users using a ldap group is not working ( CONCOURSE_MAIN_TEAM_LDAP_GROUP ).

But for the big parts, its all there and working.

Maybe the rancher-catalog is even more descriptive with the docs, try those github com/EugenMayer/docker-rancher-extra-catalogs/blob/master/templates/concourseci-cluster/25/rancher-compose.yml#L50

I guess the docs for ldap will be up in recent future anyway