BitBucket resources not being pulled in?


#1

So I’m working on a Windows machine and using VirtualBox to run an Ubuntu instance and followed this guide to setting up Concourse

My YML for my pipeline is basically just one service and a job to run unit tests and am setting my pipeline by passing in a secrets.yml with my private-key in it

Do I need to do something more for Bitbucket to allow to pull that resource in?
I feel like it might have something to do with my worker? Find screenshots below any help would be appreciated

java_service_ci_fail


#2

Some logs from the worker status when it tried to pull one of the services
This is for the small python service I’m pulling in

If more detail is needed I can provide


#3

Are the credentials you’re passing to your resource correct for accessing that bitbucket repo? Your error is the same one you would get in that scenario.


#4

Yeah i.e. the secret key. Looks like I resolved it by adding CONCOURSE_GARDEN_DNS_SERVER=8.8.8.8 to my worker.env file as I was using virtual box and it auto maps the Garden DNS to 127.0.0.1 which I don’t want apparently.
However, now I’m getting an error when I run a task which is basically this:
#!/bin/sh

pipenv install --dev
pipenv run python -m pytest


#5

The error message is telling you what’s wrong, like if you were in a Unix shell. You have to make the script executable: chmod +x ci/task.sh and commit to git.


#6

I have chmod’d it then commited it to my BitBucket repo but I still get the same error?

Successfully pulls the docker stuff it needs but then still get permission denied in Concourse?

I even tried to set privileged: true but still no luck? I’m running all this in an Ubuntu VM has it got something to do with my network?

run:
path: ci/task.sh
dir: python-service

That is in my yml file i.e. task.yml

UPDATE: looks like on windows it doesn’t actually update the permissions so I had to do
git update-index --chmod +x task.sh to actually update the permissions on my python-service

Source: https://www.emundem.ch/concourse-ci-mit-windows/